Author Topic: IMF files in Zdoom  (Read 2443 times)

Offline CHEX_MAN

  • Commonus
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 47
IMF files in Zdoom
« on: March 15, 2011, 03:55:07 PM »
I put some music from Wolfenstein 3D in the pwad using slate.  They were called unknown.  Then I went to XWE and they were called music.  Then I dragged the pwad into Zdoom and clicked on open with.  I got into the map and it should play the music D_E1M01 on the map called E1M01.  That's because I put in a MAPINFO lump.  Then when the game started, the music didn't play.

Read on if you want to read something funny.

In the Map to Wad program, the green barrels have the flats FLAT23 outside and SLIME01 in the middle.  I put FLAT23 and SLIME01 into the pwad so that they would be known.  I started the game.  The floor and ceiling, FLOOR7_1 and FLAT19 respectively were also in the pwad.  They started to move at the beginning of the level!  However, I have fixed this problem.  I forgot to put in the animation for SLIME01.  I added SLIME02, SLIME03, and SLIME04.

Offline Replica

  • What do I have to do to get Arch-Vile to like me?
  • Snot Lord
  • *****
  • Thank You
  • -Given: 20
  • -Receive: 18
  • Posts: 8420
    • Chex Quest Replica!
Re: IMF files in Zdoom
« Reply #1 on: March 15, 2011, 07:52:31 PM »
I don't think 'IMF' format is compatible in ZDoom. I'm pretty sure only .Mus, .MID, and .MP3 are usable. If I remember correctly, XWE can open more files then just doom, which is why it recognized music from Wolfenstein. I suggest downloading a midi version of the song. (Google it!)
I know what you're thinking. No, I don't like peanut butter.

If I had to choose between the real world or the Chex Quest Fan forums; I'd choose the Chex Quest fan forums.

Offline CHEX_MAN

  • Commonus
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 47
Re: IMF files in Zdoom
« Reply #2 on: March 15, 2011, 08:46:11 PM »
No.  I don't need to make a midi.  There was a page I read on the Zdoom Wiki.  It says how to fix the problem of imf not working.  Two solutions were available and I tried both.  The second seemed easier, but it didn't work on the computer.  The first (I did it second) was harder, since I needed to use a hexadecimal editor.  I at least figured out that the first five bytes for it to work would make it say ADLIB in a text editor.  So this problem's fixed.
I have converted these imf tunes to mid tunes.  They sound really bad, although the converter says it sounds better.  That is the whole reason why I wanted to keep imf in the first place.

Offline 75

  • [IFOC] Server Admin
  • Multiplayer Team Leader
  • Chex Master
  • *****
  • Thank You
  • -Given: 32
  • -Receive: 30
  • Posts: 4250
    • IFOCSERV
Re: IMF files in Zdoom
« Reply #3 on: March 15, 2011, 10:08:52 PM »
zdoom definitely does play .imf files, but not all of them.

The Blake stone .imf files are especially fussy, I ended up converting it to .raw using a winamp plugin by configuring the output device.
"Give us those nice bright colors, give us the greens of summer, makes you think all the world's a sunny day."

You can find me on the CQFF discord: https://discord.gg/AgNhjem

Offline CHEX_MAN

  • Commonus
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 47
Re: IMF files in Zdoom
« Reply #4 on: March 15, 2011, 10:55:40 PM »
I ended up converting it to .raw using a winamp plugin by configuring the output device.
I read about that one.  That is what I tried first.

Offline 75

  • [IFOC] Server Admin
  • Multiplayer Team Leader
  • Chex Master
  • *****
  • Thank You
  • -Given: 32
  • -Receive: 30
  • Posts: 4250
    • IFOCSERV
Re: IMF files in Zdoom
« Reply #5 on: March 15, 2011, 11:56:54 PM »
It works, I think you have to select the plugin in the plugins menu and configure it, it was pretty hard to figure out, actually...

I'd tell you exactly what it was, but I'm on linux right now. I'll look into it later.


EDIT

Go to options -> Preferences

In the "Winamp Preferences" window, on the left hand side there's a list of things, scroll down to the bottom, you'll see "Plug ins"

Click on "input"

Select Ad Plug from the list and hit "Configure"


In that window, select "Disk Writer (Raw Format)" as your desired output, and tell it where to put it.

To use the Disk Writer, just play the song, you have to listen to it all the way through.

After the song is done, the .raw file will appear in the directory.


Side effect : After I did that, I couldn't get winamp to play .mid files  :(
« Last Edit: March 16, 2011, 01:22:40 PM by 75 »
"Give us those nice bright colors, give us the greens of summer, makes you think all the world's a sunny day."

You can find me on the CQFF discord: https://discord.gg/AgNhjem

Offline CHEX_MAN

  • Commonus
  • *
  • Thank You
  • -Given: 1
  • -Receive: 0
  • Posts: 47
Re: IMF files in Zdoom
« Reply #6 on: March 20, 2011, 03:12:29 PM »
Sorry for the long wait to reply.  I just finished importing all the maps and fixing them.  I noticed that the tracks E1M04 and E6M10 didn't play in the game.  I went into XWE for something and looked at the music files.  I remember FloEdit saying that the usual music is >7 kilobytes.  These tracks were less than 7 kB.  I realize that track E1M03 would not work had I not needed to fix the headers.  It went from 7166 bytes to 7177 bytes.  It must be more than (or equal to; I don't know) 7168 bytes.  I also have no way to fix them again, since when I installed AdPlug, Winamp stopped working.  Is there any way to work the music tracks less than 7 kilobytes without winamp?

Wait... that was E2M04, not E1M04.  I don't get how this can be.  E2M04 music works fine, but it is the smallest imf file.
« Last Edit: March 20, 2011, 03:20:52 PM by CHEX_MAN »

 


Web Hosting by InMotion Hosting